[hihoCoder] Problem 1288 - Font Size

Steven loves reading book on his phone. The book he reads now consists of N paragraphs and the i-th paragraph contains ai characters.

Steven wants to make the characters easier to read, so he decides to increase the font size of characters. But the size of Steven’s phone screen is limited. Its width is W and height is H. As a result, if the font size of characters is S then it can only show ⌊W / S⌋ characters in a line and ⌊H / S⌋ lines in a page. (⌊x⌋ is the largest integer no more than x)

So here’s the question, if Steven wants to control the number of pages no more than P, what’s the maximum font size he can set? Note that paragraphs must start in a new line and there is no empty line between paragraphs.

Time Limit:10000ms
Case Time Limit:1000ms
Memory Limit:256MB

Input

Input may contain multiple test cases.

The first line is an integer TASKS, representing the number of test cases.

For each test case, the first line contains four integers N, P, W and H, as described above.

The second line contains N integers a1, a2, … aN, indicating the number of characters in each paragraph.

For all test cases,

1 <= N <= 10^3,

1 <= W, H, ai <= 10^3,

1 <= P <= 10^6,

There is always a way to control the number of pages no more than P.

Output

For each testcase, output a line with an integer Ans, indicating the maximum font size Steven can set.

Sample Input

2
1 10 4 3
10
2 10 4 3
10 10

Sample Output

3
2

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner sc = new Scanner(System.in);

int t = sc.nextInt();

for (int i = 0; i < t; i++) {
int n = sc.nextInt();
int p = sc.nextInt();
int w = sc.nextInt();
int h = sc.nextInt();

if (n < 1 || n > 1000 || w < 1 || w > 1000 || h < 1 || h > 1000 || p < 1 || p > 1000000)
return;

int[] a = new int[n];

for (int j = 0; j < n; j++){
int x = sc.nextInt();

if (x < 1 || x > 1000)
return;

a[j] = x;
}

int result = binarySearch(w, h, p, a);

System.out.println(result);
}
}

private static double validatePages(int mid, int w, int h, int[] a) {
double charactersPerLine = w / mid;
double linesPerPage = h / mid;
int lines = 0;

for (int i = 0; i < a.length; i++)
lines += Math.ceil(a[i] / charactersPerLine);

double pages = Math.ceil(lines / linesPerPage);

return pages;
}

private static int binarySearch(int w, int h, int p, int[] a) {
int left = 0;
int right = Math.min(w, h);
int result = 0;

while (left <= right){
int mid = (left + right) / 2;

if (validatePages(mid, w, h, a) <= p){
result = mid;
left = mid + 1;
}
else
right = mid - 1;
}

return result;
}

}